We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

Problem with login

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
There is no support for other server builds than the official provided by l2jserver.com
Post Reply
jeeroos
Posts: 4
Joined: Sun Apr 02, 2017 1:32 am

Problem with login

Post by jeeroos » Sun Apr 09, 2017 9:25 pm

Hi! I have the correct client and server, I can enter myself without problems, but my girlfriend can not. No bad protocols and no seemingly visible errors.

- Hosts: she has my external IP, I have 127.0.0.1
- Ports: open, I have tried to disable firewall and antivirus.
Ports wrote:Image
- Ipconfig.xml: renamed by removing the "default" with the following configuration:
ipconfig.xml wrote:<?xml version="1.0" encoding="UTF-8"?>
<!-- Note: If file is named "ipconfig.xml" this data will be used as network configuration, otherwise server will configure it automatically! -->
<!-- Externalhost here (Internet IP) or Localhost IP for local test -->
<gameserver address="MY IP" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../data/xsd/ipconfig.xsd">
<!-- Localhost here -->
<define subnet="127.0.0.0/8" address="127.0.0.1" />
<!-- Internalhosts here (LANs IPs) -->
<define subnet="10.0.0.0/8" address="10.0.0.0" />
<define subnet="172.16.0.0/19" address="172.16.0.0" />
<define subnet="192.168.0.0/16" address="192.168.0.0" />
</gameserver>
I repeat, I can enter without problems, but she does not. Any solutions? Thanks in advance!

User avatar
Zoey76
L2j Inner Circle
L2j Inner Circle
Posts: 6954
Joined: Tue Aug 11, 2009 3:36 am

Re: Problem with login

Post by Zoey76 » Tue Apr 11, 2017 2:15 am

May depend on the version you are using but without the file it should autoconfigure.

I think the LAN settings might be wrong somewhere around 192.168.x.x
Using Eclipse 4.15 - OpenJDK11 - MariaDB 10.4.12 - L2J Server 2.6.2.0

Sacrifice
Advanced User
Advanced User
Posts: 1022
Joined: Thu Aug 14, 2014 6:31 am
Location: España

Re: Problem with login

Post by Sacrifice » Tue Apr 11, 2017 10:08 am

Zoey76 wrote:
Tue Apr 11, 2017 2:15 am
May depend on the version you are using but without the file it should autoconfigure.

I think the LAN settings might be wrong somewhere around 192.168.x.x
Yes! Zoey76 have reason... try to config LAN conveniently
Retail GameMaster and Developer using Eclipse for Java Developers (64 bits), OpenJDK11 (64 bits), MySQL 8.0+ (64 bits).

jeeroos
Posts: 4
Joined: Sun Apr 02, 2017 1:32 am

Re: Problem with login

Post by jeeroos » Tue Apr 11, 2017 2:54 pm

Hello! I have tried different combinations, but at the minimum change I make, I see the following error in LS window, either with 1.1 or 1.4:
Could not resolve hostname "java.net.UnknownHostException: 192.168.1.0/16"
My info:
IPv4 address. . . . . . . . . . . . . . : 192.168.1.4
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . . . : 192.168.1.1

If I do not alter the default-ipconfig file to use autoconfiguration, it does not work either.


Edit: The message that appears to her is this: "Could not connect to Authentication Server. Please try again later.". I've read this topic but I do not know how to do it, I feel already something silly.

jeeroos
Posts: 4
Joined: Sun Apr 02, 2017 1:32 am

Re: Problem with login

Post by jeeroos » Sat Apr 15, 2017 3:00 pm

Problem solved. She had to put my IP in her l2.ini :+1: :wave:

Post Reply