Page 2 of 2

Re: old server not running on w10

Posted: Fri Mar 15, 2019 4:27 pm
by puredemonsss
regenx wrote:
Sat Mar 09, 2019 5:20 pm
Java and L2J on Windows OS, lol. :crazy:
Try Linux.. :+1: :wave:
this old server version is working since 2012 on java7u45x64 using w7x64 with no problem and very stable
since it was an already compiled version from here it will work without eclipse
tested it on few w7 machines and its working ok
but when tested on few w10 machines it give the error
so my question is why its giving the error on w10 specific only
tried all kinds of paths from oracle assistance to set java but same error thou the console will always say that java its ok and detected
i'm out of ideas beside the linux you say to try but how i run this old server on linux without eclipse ?

Re: old server not running on w10

Posted: Tue Mar 19, 2019 2:41 am
by regenx
I think there are two types of JAVA, one from Oracle and the standard one, not sure but you can give a try/search.

Re: old server not running on w10

Posted: Thu Mar 21, 2019 6:55 pm
by UnAfraid
regenx wrote:
Tue Mar 19, 2019 2:41 am
I think there are two types of JAVA, one from Oracle and the standard one, not sure but you can give a try/search.
For l2j there's no difference between openjdk and oracle jdk, it should compile and works fine with both

Re: old server not running on w10

Posted: Thu Mar 21, 2019 9:28 pm
by puredemonsss
well i tried all of i can think of and i think its a windows core thing
thank you all for helping really
zoey and all devs here thank you for your great programing skills making this server
if you guys have any more ideas . . .
i think ill try make an virtual w7 machine and keep it up like that . . .
waiting zoey's final response if it will work on w10 : (

Re: old server not running on w10

Posted: Mon Mar 25, 2019 3:41 pm
by puredemonsss
last thing i can think of is . . .
if someone haves an w10 machine and can test this ?
if is working on your setup then i'm doing something wrong

its the last working backup of the server i use on win7x64 using java7u45x64
https://mega.nz/#!rMNW2ILB!AePdkkBzZZxe ... ckIcN8IEeY

the folder "server" i keep it in "C:\"
in "C:\server\selective" is the backup for database

its set up on default localhost
id @ root
pass @ root
databases @ l2jcs, l2jgs, l2jls

only one account as gm if you want to log in game
id/pass its same root/root

but i think you need my client because you know . . .
just pm

- thank you again !

Re: old server not running on w10

Posted: Sun Aug 25, 2019 7:57 pm
by Zoey76
To run L2J on Windows follow this guide http://www.l2jserver.com/windows.html