We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

old server not running on w10

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
Do not post bugs reports here, use viewforum.php?f=77 instead.
There is no support for other server builds than the official provided by l2jserver.com
Forum rules
READ NOW: L2j Forums Rules of Conduct
puredemonsss
Posts: 56
Joined: Sat Dec 29, 2012 3:28 am

Re: old server not running on w10

Post by puredemonsss » Fri Mar 15, 2019 4:27 pm

regenx wrote:
Sat Mar 09, 2019 5:20 pm
Java and L2J on Windows OS, lol. :crazy:
Try Linux.. :+1: :wave:
this old server version is working since 2012 on java7u45x64 using w7x64 with no problem and very stable
since it was an already compiled version from here it will work without eclipse
tested it on few w7 machines and its working ok
but when tested on few w10 machines it give the error
so my question is why its giving the error on w10 specific only
tried all kinds of paths from oracle assistance to set java but same error thou the console will always say that java its ok and detected
i'm out of ideas beside the linux you say to try but how i run this old server on linux without eclipse ?

User avatar
regenx
Posts: 308
Joined: Sat Jul 17, 2010 6:55 am

Re: old server not running on w10

Post by regenx » Tue Mar 19, 2019 2:41 am

I think there are two types of JAVA, one from Oracle and the standard one, not sure but you can give a try/search.

User avatar
UnAfraid
L2j Veteran
L2j Veteran
Posts: 4198
Joined: Mon Jul 23, 2007 4:25 pm
Location: Bulgaria
Contact:

Re: old server not running on w10

Post by UnAfraid » Thu Mar 21, 2019 6:55 pm

regenx wrote:
Tue Mar 19, 2019 2:41 am
I think there are two types of JAVA, one from Oracle and the standard one, not sure but you can give a try/search.
For l2j there's no difference between openjdk and oracle jdk, it should compile and works fine with both
Image

puredemonsss
Posts: 56
Joined: Sat Dec 29, 2012 3:28 am

Re: old server not running on w10

Post by puredemonsss » Thu Mar 21, 2019 9:28 pm

well i tried all of i can think of and i think its a windows core thing
thank you all for helping really
zoey and all devs here thank you for your great programing skills making this server
if you guys have any more ideas . . .
i think ill try make an virtual w7 machine and keep it up like that . . .
waiting zoey's final response if it will work on w10 : (

puredemonsss
Posts: 56
Joined: Sat Dec 29, 2012 3:28 am

Re: old server not running on w10

Post by puredemonsss » Mon Mar 25, 2019 3:41 pm

last thing i can think of is . . .
if someone haves an w10 machine and can test this ?
if is working on your setup then i'm doing something wrong

its the last working backup of the server i use on win7x64 using java7u45x64
https://mega.nz/#!rMNW2ILB!AePdkkBzZZxe ... ckIcN8IEeY

the folder "server" i keep it in "C:\"
in "C:\server\selective" is the backup for database

its set up on default localhost
id @ root
pass @ root
databases @ l2jcs, l2jgs, l2jls

only one account as gm if you want to log in game
id/pass its same root/root

but i think you need my client because you know . . .
just pm

- thank you again !

User avatar
Zoey76
L2j Inner Circle
L2j Inner Circle
Posts: 6912
Joined: Tue Aug 11, 2009 3:36 am

Re: old server not running on w10

Post by Zoey76 » Sun Aug 25, 2019 7:57 pm

To run L2J on Windows follow this guide http://www.l2jserver.com/windows.html
Using Eclipse 4.12 - OpenJDK11 - MariaDB 10.4 - L2J Server 2.6.1.0

Locked